I’ve been an avid Adobe Photoshop Elements user since the days that Livejournal.com was hot in my middle school. I loved it! It was easy to use and inexpensive. I even had my own little icon request webpage and I enjoyed making graphics for other users. Well, my passion never died and I carried my […]
" />

Adobe Photoshop Elements 4.0 NOT Compatible with Leopard

Adobe Photoshop Elements 4.0 for MacI’ve been an avid Adobe Photoshop Elements user since the days that Livejournal.com was hot in my middle school. I loved it! It was easy to use and inexpensive. I even had my own little icon request webpage and I enjoyed making graphics for other users. Well, my passion never died and I carried my love into making graphics for MySpace layouts. When I switched to Mac two years ago, I immediately purchased Adobe PE 4.0 for Mac. It worked just the same as it did on my old Windows system. I was a little disappointed when Windows received a new version of PE and Mac didn’t, but I was happy with my version so I didn’t think too much about it.

When I upgraded to Leopard I didn’t even think about it, I just assumed that all my existing software would work. I uploaded Adobe PE 4.0 onto Leopard and all seemed fine. Actually, all seemed fine for several months! Until one day, I couldn’t change the sensitivity value on the selection tool. I quit PE and re-opened it and still couldn’t change the value. From there, thing’s just got stranger! Everything began falling apart and soon enough, PE was unusable.

I decided to Google the issue and came to discover that I was lucky the program even loaded after my Leopard upgrade! It shouldn’t have worked in the first place! Why? Because it’s not compatible. Excuse me?! My beloved Adobe is allowing this to happen? I was in disbelief that, not only is Mac two updates behind Windows but there isn’t even a fix available for PE 4.0 on Leopard! I, personally, find this disgraceful.

How can Adobe do nothing while thousands of PE users are left with an unusable program?

Continue reading:

TAGS: