It looks like you’ll need at least an iPhone 3GS or an iPod Touch 3rd generation to run the upcoming iOS 4.3 – or at least that’s the assumption based on the fact that there are no downloads of the beta available for the iPhone 3G or iPad Touch 2G. If this is the […]
" />

iOS 4.3 Drops Support for iPhone 3G and iPod Touch 2G

iOS43DropsSupport

 

It looks like you’ll need at least an iPhone 3GS or an iPod Touch 3rd generation to run the upcoming iOS 4.3 – or at least that’s the assumption based on the fact that there are no downloads of the beta available for the iPhone 3G or iPad Touch 2G.

If this is the case, I don’t think there’s too much to complain about here – limited support for devices over two years old does not seem an outrageous stance to me. Your thoughts on this?

News Via: 9to5Mac

Continue reading:

TAGS: