Will I be able to run OS X Yosemite on my current Mac? That's a big question many of us had after the keynote presentation this week. With so many awesome new features and upgrades added to both iOS 8 & OS X Yosemite, in addition to their new deep integration, Yosemite is a very desirable upgrade.
" />

Will my Mac be compatible with OS X Yosemite?

OSX 10 Yosemite

Will I be able to run OS X Yosemite on my current Mac?  That’s a big question many of us had after the keynote presentation this week.  With so many awesome new features and upgrades added to both iOS 8 & OS X Yosemite, in addition to their new deep integration, Yosemite is a very desirable upgrade.

Have no fear, even those of you like myself, rocking an older device like my 2008 MBP, will still be able to upgrade to OS X Yosemite.  Apple has kept the system requirements exactly the same as they did for the upgrade to OS X Mavericks.  All of the following Mac computers that supported Mavericks will now also support Yosemite

  • Mac mini / early 2009 or newer
  • MacBook / late 2008 aluminum version & early 2009 or newer
  • Mac Pro / early 2008 or newer
  • iMac / mid 2007 or newer
  • MacBook Pro / mid 2007 or newer
  • MacBook Air / late 2008 or newer

Continue reading:

TAGS: , , , , ,